Correction petits bugs

Bon visiblement ça me le fait plus >>. Je suis sur chrome.
Ca le faisait pour plusieurs personnages (ça me l’a fait pour 3) et oui que dans le champ background.

Bon mystère…

@Albanbou je t’ai envoyé un mail car je n’arrive pas à reproduire le bug.

Oui, alors ça fait le bug dans l’affichage “preview” d’un document lié à un groupe mais pas dans le document en lui-même.

Regarde ici en bas de page :

https://larpwriter.herokuapp.com/fr/larps/789/groups/200777

Ah ok… je regardais dans la page du document. Je viens de regarder dans la page du groupe et j’y vois le bug. Je viens de corriger manuellement, le bug n’apparaît plus. Il semble que la description du document vient d’un copier-coller non ? Quand on copie-colle depuis Word ou une autre source vers un éditeur de texte dans un navigateur, l’éditeur de texte fait au mieux pour convertir le texte collé vers du HTML “propre” mais ce n’est pas 100% fiable.

Oui je pense que c’est ça, une balise qui a dû rester, mais on ne peux pas éditer le code sur larpwriter (et c’est très bien, on est pas là pour ça ^^ )

Merci en tout cas!

Sinon, l’icône de retour à la page d’accueil dans le menu en haut est un peu petite et représente plutôt une « déconnexion » qu’une page d’accueil (symbolisée plutôt par une picto de maison) :wink:

Bonne journée!

Alban

Merci pour la suggestion Alban ! J’ai changé l’icône de retour à la page d’accueil.

Et du coup… pourquoi ne pas mettre l’icône tout à gauche ? :wink:

(c’est marrant, quand on répond par mail au message, ça poste aussi directement ici! Heureusement que j’ai pas dit de bêtises ^^)

Parce que je suis de droite !!!

Non en fait pas de raison particulière, je préfère juste voir l’icône à droite.

J’ai un bug sur le champ “Autres noms” :

sur un document nommé “Duché de Montfort”, le champ “Autres noms” ne fonctionne pas avec les mots “Duché” “de” et “Monfort”

du coup c’est ennuyant dans ce cas particulier, je veux juste qu’à chaque fois que le mot Monfort soit cité quelque part , on puisse aller sur le document sus-nommé.

Je crois savoir pourquoi …

Le lien ne se crée pas si plusieurs éléments portent le même nom; ce qui est le cas avec “Duché” “de” et “Monfort”

@chooov merci, je vais corriger ce bug, j’espère la semaine prochaine.

Merci Flo, c’est corrigé sur mes GN

Salut !
Quand on ajoute un élément à inclure dans un perso, on ne peut plus le modifier ensuite, il faut le supprimer puis en recréer un nouveau, pourquoi ? (dans ma manip, je m’étais trompé en ne faisant apparaître l’élément uniquement aux orgas alors que le joueur devait le voir aussi. Mais c’est le même problème si on s’est trompé d’élément dans la liste).

Autre truc dont je me suis aperçu, quand on clique plusieurs fois sur l’icône “cliquer pour modifier ce champ”, ça ouvre à chaque fois un nouveau champ de modification, même s’il y en a déjà un identique d’ouvert ^^ c’est une source d’erreur et de bug.

EDIT : en fait ça ne fait ça que pour les champs visibles des orgas et des joueurs. Ça ne fait pas ce bug que le champ est uniquement visible des orgas.

Merci @Albanbou j’ai ajouté ces bugs à Prochaines améliorations et corrections de bugs, je les corrigerai.

1 J'aime

Salut, peut-être que ça a déjà été dit, mais quand un champ à un nom (comme les champs attribués à un modèle), si on modifie le contenu de ce champ et qu’on sauve la modification, le nom du champ disparaît :

Presse-papier01 > > >Presse-papier02

Petit bug dans le graphe des relations, quand on passe sur un lien de relation (flèche entre 2 pastilles), la description s’affiche mais il n’y a pas de retour à la ligne, du coup le texte sort de l’écran.

@Albanbou merci pour ces rapports de bug, ça va avancer le schmilblick :clinking_glasses: J’ai corrigé la sortie de texte pour les liens du graphe de relations. Par contre je n’arrive pas à reproduire ce bug :

Salut, peut-être que ça a déjà été dit, mais quand un champ à un nom (comme les champs attribués à un modèle), si on modifie le contenu de ce champ et qu’on sauve la modification, le nom du champ disparaît :

Peux-tu m’envoyer par email un exemple précis (URL de la page, nom du champ, etc.) ?

Autre truc dont je me suis aperçu, quand on clique plusieurs fois sur l’icône “cliquer pour modifier ce champ”, ça ouvre à chaque fois un nouveau champ de modification, même s’il y en a déjà un identique d’ouvert ^^ c’est une source d’erreur et de bug.
EDIT : en fait ça ne fait ça que pour les champs visibles des orgas et des joueurs. Ça ne fait pas ce bug que le champ est uniquement visible des orgas.

@Albanbou Pour bien comprendre : tu ne souhaites qu’on ne puisse modifier qu’un seul champ à la fois, c’est bien ça ? Par exemple si l’on est en train de modifier Background qu’on ne puisse modifier Personnalité qu’après avoir cliquer le bouton “sauver” ou “annuler” de l’édition de Background.

Non c’est pas ça. C’est quand on clique sur le crayon pour modifier un chant de relation ou d’orga, d’habitude pendant l’édition, le nom du champ disparaît ainsi que les icônes crayon, poubelle et double-flèches. Mais là non, ça reste, donc on peut encore cliquer sur le crayon et ça rouvre un deuxième champ de modification,et ainsi de suite.
Je t’envoies une capture d’écran en mp.

Alors ce n’était pas ma demande mais ça serait une restriction où il y a du pour et du contre :

  • ça éviterait qu’on perde des données si on est en train de modifier plusieurs champ et qu’on rafraichit la page par erreur en oubliant qu’on a un autre champ en cours de modification.
  • mais ça empêcherait des copier/coller (RIP Larry Tesler) parfois bien pratique entre deux champ tout en conservant la mise en forme du texte.

Le mieux serait donc de laisser la possibilité de modifier plusieurs champ d’un page en même temps, mais d’afficher un pop-up en cas de rafraîchissement de page ou de fermeture de page si un des champs de la page est toujours en cours de modification.